Open F.I.R. > Plan-G

Connecting SimConnect to P3dv4 in Plan-G 3.2

(1/1)

tim arnot:
The P3D SimConnect library uses a much more "traditional" approach to connections than the beta FSX library. Here's how to set it up.

1.Create a Simconnext.xml file on the P3D computer, in the folder C:\Users\(me)\AppData\Roaming\Lockheed Martin\Prepar3D v4

Paste in (or type) the following:


--- Quote ---<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect Server Configuration</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>

<!-- Example Global (remote) IPv4 Server Configuration-->
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <MaxClients>64</MaxClients>
    <Address>192.168.0.106</Address>
    <Port>4504</Port>
  </SimConnect.Comm>

</SimBase.Document>
--- End quote ---

Note the items in bold: "Address" is the IP address of your P3D PC. You can find it out by using the IPConfig command from a cmd prompt.
"Port" can be any free port number. You will need to remember it for the next step.

If you already have a Simconnect.xml and it's being used by some other addon, simply add a new entry to that file.

2. In your Plan-G program folder, create a Simconnect.cfg file.
Paste or type in the following:


--- Quote ---[SimConnect]
Protocol=IPV4
Address=192.168.0.106
Port=4504
MaxReceiveSize=4096
DisableNagle=0
--- End quote ---


Note that the address and port numbers should be the same as those in the xml file.

Now, when you want to see your P3D aircraft in Plan-G, select "Simconnect (P3D) in the connect options, and click Connect.

If the connection should time out, check your application permissions (if P3D is running as Administrator, Plan-G must also run as Administrator), and make sure your firewall or antivirus is not blocking it.

Supplemental: You should set up your router to reserve an IP address for your P3D computer. This means that it will have the same address on your internal network every time you start it. If you just leave it to the default allocation, it could get different addresses each time, and you'll need to update both the xml and cfg files accordingly. Trust me, this is a pain in the butt.

Navigation

[0] Message Index

Go to full version