TA Software

Open F.I.R. => Plan-G => Topic started by: barree on September 17, 2011, 02:28:27 PM

Title: Connecting Plan G over network (simconnect) TIP
Post by: barree on September 17, 2011, 02:28:27 PM
I had a similar problem like many others for connecting to FSX with PlanG on a laptop over the network. I've setup PlanG exactly as explained in the manual but still every time PlanG was disconnected after about 20seconds because of timeout.

I've tried many of the solutions given in this forum, but what really did the trick for me was a small free utility called the "SimConnect config tool" (http://simconnectconfigtool.codeplex.com/ (http://simconnectconfigtool.codeplex.com/)).

Just wanting to help others with the same problem, I decided to share my knowledge...

Beautifull program by the way, thumbs up!
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: Superglide on November 08, 2011, 08:35:30 PM
Thank you!
I have been struggling with simconnect connections. I loaded this app, filled in the data as requested and connected from my lap top to my PC on the first try!
You rock!

Supe
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: ajmlans on December 14, 2011, 10:00:34 AM
Tanks,I try this tip, and its work fine
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: bpearson on October 11, 2012, 01:50:51 PM
Does anyone have something that will work on one computer??????
                                                                                                                       bpearson
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: claude101141 on November 11, 2012, 09:33:50 PM
Tanks,I try this tip, and its work fine

Hi,

I must be very stupid but I don't understand how to use and implement this tip. I'd be very grateful if you could
give more details on how to do the trick.

Thanks in advance

Claude
Paris-France
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: paul123 on November 18, 2012, 05:36:52 PM
Somewhere on this forum gave me the answer, for some reason the IP addresses would not match up, so I just use the name of my computer under "Users" instead of the IP address and it connects fine. Just make sure it is the same in the Simconnect.xml and in settings in PlanG.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: claude101141 on November 18, 2012, 09:44:29 PM
 Thanks Paul; just a precision are you using Windows 7 ? Because under users in Win 7 you do not have the
name of the computer but the user's name. It is in configuration management system option that you can
find it. I ask this as to make sure we talk about the same thing..
Claude
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: miloguy on March 30, 2013, 09:32:33 AM
G'day every one

I too have been struggling with trying to get this to work
over my wifi .. read all instructions and tips here but still no luck.. got it on both pc and laptop,
i can get Vatsim to work but not connect to work

so frustrated..

milo
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: tim arnot on March 30, 2013, 10:03:42 AM
G'day every one

I too have been struggling with trying to get this to work
over my wifi .. read all instructions and tips here but still no luck.. got it on both pc and laptop,
i can get Vatsim to work but not connect to work

so frustrated..

milo

Create a support post, including a copy of your simconnect.xml, the log output from Plan-G and the results from running IPConfig on both PCs, and we'll try to get you sorted out. :)
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: miloguy on April 02, 2013, 12:56:09 PM
say that again in english please??
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: sky one on April 02, 2013, 09:55:36 PM
say that again in english please??
Attach:
1) simconnect.xml
2) plan-g log (you can find it in the "Plan-G Files" folder, under "My Documents")
3) on both PCs open a command prompt, type
ipconfig > ip.txt
and attach both ip.txt files.

Better now?  :)
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: Swazi98kl on April 04, 2013, 05:50:21 PM
I have copied over the 157MB Data folder to my networked laptop and tried to open PlanG3_FSX. Windows does not recognize this file. SQL Server Compact Edition Database file (sdf) ? Help please. Both laptops running Windows 7

Thanks
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: farsenea on May 27, 2013, 05:21:46 PM
Is there something different in the new 3.0.4 version ?

I am using v2 & was using a previous version on v3 on a laptop on WiFi to connect to my FSX PC using SimConnect & IP4 with no problem but now, it always crash when trying to connect with the new 3.0.4 version. I validated my v2 config & my SimConnect.xml file & I even change using the IP to using the name of my FSX PC with no success fo the v3.0.4 version (v2 is still working fine on the same laptop now using the name instead of the IP). My laptop if Win 7 & my FSX PC is Vista

What would the utilityi n the first post would do to me in this case ?

Thanks
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: tim arnot on May 28, 2013, 12:44:51 AM
I had it crash on me today while connecting across wifi, so yes, I am investigating what this could be.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: miloguy on July 10, 2013, 01:23:03 PM
i had been trying for yonks to get this going with my laptop over my wifi
and finally tonight i did it, try ticking in the properties of plan g on the desk top or
where ever the short cut is and click on run as administrator ... might work for you, might not
but worh a try...

milo
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: farsenea on July 10, 2013, 08:46:21 PM
I am already running it with the administrator option - does not work for me :-(
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: Hash on September 19, 2013, 11:00:56 AM
Hello,
On the simconect program what need to be filled in?
Thanks
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: lambo93 on November 23, 2013, 11:54:23 PM
i have recently installed simconnect properly (I think)

But every time i click on connect on plan g3 it crashes, yet if i set the option to FSUIPC it dosen't crash.
I am looking to get FSUIPC if i cannot get this to work, but i don't really want to pay out for the licences
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: farsenea on December 05, 2013, 01:28:43 AM
I had it crash on me today while connecting across wifi, so yes, I am investigating what this could be.

Hi Tim,

It still crash on me with the v3.0.7.71 version (v2 still work): did you find anything so far ?

Thanks
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: THibben on January 05, 2014, 04:49:15 AM
I have installed V3 on my networked computer.  The computers are talking to each other.  When I Install FSX it is connected the second computer and Wide FS says it is connected to the main PC.  The problem I have is when I open V3 I only have access to loading data and when I try I am not able to connect to FSX.  I have tried copying the data files into V3 but they are still not being read.

Any help will be appreciated as I have been working on this for three days.  Thanks in advance.

Tom
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: farsenea on January 05, 2014, 04:20:51 PM
I had it crash on me today while connecting across wifi, so yes, I am investigating what this could be.

Hi Tim,

It still crash on me with the v3.0.7.71 version (v2 still work): did you find anything so far ?

Thanks

For your information, I can make v3 work with IPv6 but not IPv4 - this is good enough for me for now :-)
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: exgringo on January 25, 2014, 06:21:27 PM
After the many problems I have encountered with SimConnect the price of fsuipc seems VERY reasonable.  Any networked program on my PC that uses WideFS works immediately after installing...no hassle.
I have been trying for two months to get a couple of programs to work on SimConnect..
Bless plan-G for its ease of use.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: CL0UDSCAPE on March 10, 2014, 11:07:26 AM
It seems to me that the more security conscious Microsoft got, the less user friendly they became, as well as their interest in developing Flight Simulator into the best that it could be! Unfortunately, I've always struggled between hardware and software upgrades and compatibility! FSX, FSIX, and X-Plane are all running on my Windows Vista Ultimate machine and I'm trying to network Plan-G running on my Windows 8.1 Notebook because it's so much more powerful! With a little bit of persistence and luck I got fs_earth_link and FlightConnect(on my Android Tablet) to work, but have had no luck with Plan-G.  I'm kind of hung up over Permissions and Accessibility between these operating systems and spent hours attempting to work things out! Since FSTramp didn't have a planner, I was amazed at  the sophistication of Plan-G only I'm still "put off" by not getting things working over my network!  I'll keep on trying but it seems so hopless!
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: Bandr35 on May 15, 2014, 02:59:14 PM
1. To network PC to PC, don't you have to use a crossover ethernet cable?
2. AFIK both PCs must use the same OS. A Windows 8.1 PC can not be networked to a Windows 7 PC.
3. Does PLANG have a work around for different PC operating systems?
Thanks, Ron 
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: ThWind81 on May 16, 2014, 01:06:19 AM
I have done everything described in an attempt to use simconnect to use plan g on my laptop with fsx on my main pc.  I created the IPv4 version of a simconnect.xml file and put it in the same directory as fsx.cfg.  I just copied what was in the users guide and made sure my port was entered correctly in plan g. I opened that port in my router as well just to be sure. I have tried disabling all antivirus firewalls on both computers.  I am stubborn and can usually get things to work. I am very frustrated now. What gives?  Can someone give me a simple list of the things I need to do so I can make sure I didn't miss anything?    I haven't done anything with simconnect other than make sure it was loaded by installing it off the fsx disc onto my main fsx computer. Do I need to load it on the laptop running plan g as well?
FSX Gold with acceleration
Plan g 3.1.0.82
Windows 7 home premium 64bit on both computers

Oh yeah.. I did see in the users guide that the .xml file was proven to work in windows xp. Could this be an issue with windows 7 compatibility?
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: Novawing24 on May 16, 2014, 02:41:30 AM
I also am having issues since the latest version. I have 2 windows 8.1 devices (Desktop and Surface Pro2) everything ran fine using IPv4 in the last release of the software however with this version nothing.

I have tried IPv4/IPv6/SimConnect everything except FSUIPC/WIDEFS because I do not have that yet.

I am curious to know what solutions have been found if any or work arounds. Although I am hesitant to get it, if FSUIPC/WDIEFS will fix my issue I am just about ready to buy it.

Alternatively can we get the prior stable release so I can roll back to that version (lost my copy in a HDD failure)

Safe Skies

Novawing24
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: mmaier on May 16, 2014, 06:34:51 AM
I have a 8.1 PC and a XP PC configuration.
on 8.1 run FSX
on XP run Plan-G3  3.0.7.71

The SimConnect.xml file should be at ( 8.1 PC )
C:\Users\your name\AppData\Roaming\Microsoft\FSX

The Contens:
<?xml version="1.0" encoding="WINDOWS-1252"?>
-<SimBase.Document version="1,0" Type="SimConnect">
<Descr>SimConnect</Descr>
<Filename>SimConnect.xml</Filename>
<Disabled>False</Disabled>
-<SimConnect.Comm>
<Protocol>IPv4</Protocol>
<Scope>global</Scope>
<Address>192.168.2.yyy</Address> !!!! from your FSX PC the same into Plan-G PC
<MaxClients>64</MaxClients>
<Port>9017</Port>
<MaxRecvSize>4096</MaxRecvSize>
<DisableNagle>False</DisableNagle>
</SimConnect.Comm>
</SimBase.Document>

This works for me without any Problem

Manfred
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: Novawing24 on May 23, 2014, 07:35:38 AM
Thanks for the assist mmaier, however sadly I must report it has not fixed the issue.

Cheers

Novawing24
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: mikebuddy on July 06, 2014, 11:13:49 AM
I presume you have tried FSUIPC4 & WideFS. Although I have Simconnect for my networked weather (ASN)  I'm pretty sure it's FSUIPC that's running my planG cause if if I do not fire up WideFS than it will not load the aircraft symbol on the map. Worth a try. :azn:
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: rogerover on July 27, 2014, 03:10:22 PM
My own feedback :

Plan-G v 3.1.1.93 works fine remotely on my laptop XP SP3 with both FSX and P3D v1.4 with the following simconnect.xml file located where it should be:

<?xml version="1.0"?>
<SimBase.Document Type="SimConnect" version="1,0">
   <Descr>SimConnect</Descr>
   <Filename>SimConnect.xml</Filename>
   <!-- Example Global (remote) IPv4 Server Configuration-->
   <SimConnect.Comm>
      <Disabled>False</Disabled>
      <Protocol>IPv4</Protocol>
      <Scope>global</Scope>
      <Address>jlldesktop</Address>
      <MaxClients>64</MaxClients>
      <Port>4506</Port>
      <MaxRecvSize>4096</MaxRecvSize>
      <DisableNagle>False</DisableNagle>
   </SimConnect.Comm>

<SimConnect.Comm>
<Disabled>False</Disabled>
<Protocol>Auto</Protocol>
<Scope>local</Scope>
</SimConnect.Comm>
</SimBase.Document>


It does not work with P3Dv2.2 with the same simconnect.xml except if P3D v2.2 is launched in legacy mode wich is an option of Estonian Migration Tool. Strange enough to be mentionned !!

FSX, and P3D are running on my desktop under W7-64 french version
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: John Lygo on October 23, 2014, 03:29:25 PM
Yesterday afternoon, Peter and I  - well, Peter, really - managed to get my new computer seeing FSInn and it worked fine. However, the same could not be said for Plan-G unfortunately. I have FSX with Acceleration and Plan-G on my Win7 machine and Plan-G on my Vista machine. I got FSX running on the Win7 machine, and P-G on the Vista machine. So far so good. However, when I tried to connect P-G to FSX over the network, P-G crashed. I got the usual 'Plan-G has stopped working etc', then it closed. I can connect P-G to FSX when running both on the Win7 machine - no problems.
Vista machine ip = 192.168.0.2
Windows7 machine ip = 196,168.0.10
Here is a copy of the simconnect.xml file...
<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="SimConnect" version="1,0">
   <Descr>SimConnect</Descr>
   <Filename>SimConnect.xml</Filename>
   <SimConnect.Comm>
      <Disabled>False</Disabled>
      <Protocol>Auto</Protocol>
      <Scope>local</Scope>
      <Address>192.168.1.10</Address>
      <MaxClients>64</MaxClients>
      <Port>4506</Port>
      <MaxRecvSize>4096</MaxRecvSize>
      <DisableNagle>False</DisableNagle>
   </SimConnect.Comm>

   <SimConnect.Comm>
      <Disabled>False</Disabled>
      <Protocol>IPv4</Protocol>
      <Scope>global</Scope>
      <Address>192.168.1.10</Address>
      <MaxClients>64</MaxClients>
      <Port>4506</Port>
      <MaxRecvSize>4096</MaxRecvSize>
      <DisableNagle>False</DisableNagle>
   </SimConnect.Comm>
</SimBase.Document>
I have attached a copy of the P-G log.
Hoping you can make sense of the situation.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: tim arnot on October 23, 2014, 06:48:54 PM
You are not establishing a connection. Looking at your simconnect.xml, you seem to have two listeners competing for the same IP/port combination. I'd suggest you change the "Auto" connection to a different port, or delete it. Other than that, make sure that the IP is correct and that you can ping between machines.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: John Lygo on October 24, 2014, 10:45:07 AM
Got it sorted Tim, thanks. Changed the ip address to 192.168.0.10 and all is well now. Cheers.
Title: Re: Connecting Plan G over network (simconnect)
Post by: jrocky on November 02, 2014, 11:04:31 PM
Having Plan-G simconnect issues. Attaching log zip file with simconnect xml under the log file. Recently installed a new motherboard, there might be some issue there but not sure. I can view files from the computer running Plan-G and the FSX computer. Looked at the BIOS configuration of the motherboard and can not see any setup that might cause failure of connecting two computers over local network. Also the router configuration is set to allow the Plan-G MAC address to pass though the router firewall.

The motherboard is a Gigabyte GA-990FXA-UD3 with AMD FX 6300 6-core 3.5Ghz processor. 

jrocky
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: tim arnot on November 03, 2014, 08:43:09 AM
Could you please attach the logs as plain text - I'm not sure what you did, but I can't open that zip file. Thx.
Title: Re: Connecting Plan G over network (simconnect)
Post by: jrocky on November 03, 2014, 01:34:32 PM
Tim,
Here is the log file and simconnect xml in plain text.

jrocky
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: tim arnot on November 03, 2014, 03:06:37 PM
The first thing to check is that you can ping the IP6 link-local addresses of both machines, in each direction. If you've got a old switch in your network, you may find it does not pass IP6 traffic correctly, for instance.

If that doesn't resolve it, I'd suggest trying IPv4.
Title: Re: Connecting Plan G over network (simconnect)
Post by: jrocky on November 03, 2014, 06:02:21 PM
Was able to ping both ways on both computers. Changed SimcConnect.xml to Ip4 also on Plan G connection. Times out same as the log file I attached in previous message.  The fault may be with the other computer I am trying to network. Running Windows 10 Technical Preview Evaluation copy, Build 9860.

There is a form for Windows 10 issues, will post on that form and see if anyone has an answer.

jrocky


Title: Re: Connecting Plan G over network (simconnect)
Post by: jrocky on November 04, 2014, 01:30:38 PM
Borrowed a laptop with Windows 7 Professional 64 bit. Installed Plan-G, configured router to pass laptop MAC and IP addresses. Plan-G still timed out using IPv6 and IPv4 SimConnect.xml. Plan-G times out and shuts down. Must be something in the motherboard BIOS that I am not configuring correctly? Running Windows 7 Professional 64 bit on the FSX computer. IPv6 and IPv4 enabled for Windows networking on the FSX computer. Not sure what I need to configure to have network SimConnect working? Plan-G runs on the FSX computer fine using 'localhost' with FSX running in Windowed mode.

jrocky

Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: tim arnot on November 04, 2014, 02:01:07 PM
Ok, confirm that the IP is for the FSX PC and no the Plan-G one. Then try using a different port number (e.g. 4567) - maybe that port is already in use on your system.
Title: Re: Connecting Plan G over network (simconnect)
Post by: jrocky on November 04, 2014, 08:26:29 PM
Finally able to connect Plan-G from computer running Windows 10 Technical Preview Evaluation copy. Build 9860 to computer running FSX on Windows 7 Professional 64 bit.  :) Changing the port to 4567 and using IPv4 worked. Had an idea that this would work as after changing SimConnect.xml to IPv4 and port to 4567, loading FSX the dialog error message appeared advising that the port was being blocked. Had the option to allow the port on the Home network, selected allow option.

Thanks for all the assistance Tim!

Windows 10 will be released in 2015, no exact date has been posted. Windows 10 seems to be a little more user friendly than Windows 8.1. I understand Microsoft has stopped selling Windows 8 via DVD or on OEM computers. Windows 8.1 is the current OS that Microsoft is selling. Windows 10 opens in Desktop view, when clicking the Start button, the menu like Windows 7 appears along with app tiles to the right of the menu. One can remove, resize app tiles or remove them completely. Windows 10 Technical Preview is free OS http://windows.microsoft.com/en-us/windows/preview-iso (http://windows.microsoft.com/en-us/windows/preview-iso). Note if your running any previous Windows OS on a computer it will overwrite that OS so have your factory image saved so you can go back to a previous version of Windows. I have not tried dual boot Windows 7/10 configuration as of yet.

jrocky

Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: Smokeywood on November 10, 2014, 01:17:36 AM
Greetings

I have been searching the forum and reading and making adjustments for
about 2 weeks now trying to get plan g3 on my laptop to connect to my fsx
on my desktop computer.

Finally it struck me where I had installed plan g on the laptop and I had installed
it in the program files (x86) folder.

When I uninstalled from that folder and reinstalled on drive c in folder of its own
and set the connection settings it connected the first time/

Hope this may help others.

Gene
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: John Lygo on November 19, 2014, 04:42:03 PM
For some unknown reason my Plan G will now not connect to FSX over the network. It connected fine the other day & I have done nothing to the connection parameters. Is this due to the vagaries of simconnect or is something else at work here. Attached is my PG log file and below is a copy of my simconnect file.

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="SimConnect" version="1,0">
   <Descr>SimConnect</Descr>
   <Filename>SimConnect.xml</Filename>
   <SimConnect.Comm>
      <Disabled>False</Disabled>
      <Protocol>Auto</Protocol>
      <Scope>local</Scope>
      <Address>192.168.0.3</Address>
      <MaxClients>64</MaxClients>
      <Port>4506</Port>
      <MaxRecvSize>4096</MaxRecvSize>
      <DisableNagle>False</DisableNagle>
   </SimConnect.Comm>

   <SimConnect.Comm>
      <Disabled>False</Disabled>
      <Protocol>IPv4</Protocol>
      <Scope>global</Scope>
      <Address>192.168.0.3</Address>
      <MaxClients>64</MaxClients>
      <Port>4506</Port>
      <MaxRecvSize>4096</MaxRecvSize>
      <DisableNagle>False</DisableNagle>
   </SimConnect.Comm>
</SimBase.Document>

Hope you are able to throw some light on this situation Tim.
Cheers.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: tim arnot on November 19, 2014, 05:58:48 PM
Did you restart something and get assigned a different IP address?
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: John Lygo on November 20, 2014, 08:49:33 AM
That was it Tim, thanks. So how & why does that happen?
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: tim arnot on November 20, 2014, 02:01:15 PM
If you haven't told your router to reserve a specific IP for your FS machine, it can get a different one every time you boot. Then you'll have to go through and change all your configs each time.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: FlyingAxx on November 20, 2014, 04:52:28 PM
Usually the router I know are giving a lease and renewing it each time.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: domkle on November 22, 2014, 06:00:12 PM
After struggling for quite a while, my connexion works today. For what it is worth and if that may help  a fellow simmer, I realised that the simconnect.xml was somewhat corrupted when I tried and couldn't  open it with the xml editor while it was perfectly readable with the Notepad with what I had initially written it. Rewriting the few same lines in a new xml did the trick. Using P3D with W7 and IPV6.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: vtristram on April 13, 2015, 08:48:43 PM
I was ( still am ) having the same problems described here. After many hours of fruitless variations and configs, I gave up and tried FSUIPC/WideFS: lo and behold: it worked first time!
However, I still can't understand why SimConnect doe not work with my setup now. The funny thing is, I had it running fine with P3D v2.4. I then upgraded to 2.5 via hotif(es)...and it never worked again. Now I know everybody says in a situation like this "I didn't change anything else..." and I do know that you really cannot guarantee that...BUT it still puzzles me very much why PG stopped working. I checked and re-checked the SimConnect.xml in my P3D folder, even copied the contents from the PG manual, changed the URL, of course... checked the settings in PG... tried it on different PCs/laptops  I do not know why SimConnect cannot connect and times out.
My logfile syas the same thing as in the numerous posts here.
Can anyone help?
Volker
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: hlminx on August 02, 2015, 11:35:22 AM
Hi All
I've had nothing but problems trying to connect via a network and after a day and a half wasted troubleshooting, I'm still no closer.

Both PCs are running Win7, both are connected to the Home Network and can see each other, but as soon as I press the Connect button, it waits for 2-3 seconds and then just crashes. The log appears to indicate the " SimConnect connection attempt timed out"

I have tried:

Turning off the firewall on both
Turning off the antivirus on both
I have 'pinged' both PCs and they can see each other fine
Used the automatic IP address
Re-set the FSX computer to a Static IP address (then changed it back to a dynamic one when Static didn't work)
Changed the Port from 4505 to 4506  to 4507 and 4508.. no joy
Tried setting up the SimConnect.XML as IPV6  AND IPV4  - (when I found that IPV6 wasn't working I re-wrote the SimConnect.xml to IPV4, but realised that each time I changed the details in the Location option on PlanG that it decided to keep reverting to the IPV6 settings so I had to uninstall PlanG, delete all the folders that were still on my HD, and cleared the registry... )
Tried all IPV6 and IPV4 versions of the 'Templates' included in the PlanG User Manual, to no avail
I managed to stop the software crashing by clicking the FSUIPC instead of SimConnect but then it just sat there doing nothing
I tried a 'Sim Connect config tool' but that made no difference

Below is my last Log and the XML  in case anyone has any bright ideas ??
Advice most welcome..
Regards
Minx

My Ips are: FSX machine 192.168.1.148 (dynamic)       PlanG machine: 192.168.1.149 (dynamic)

My Sim Connect .XML is:
<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
<SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>Auto</Protocol>
    <Scope>global</Scope>
    <Address>192.168.1.148</Address>
    <MaxClients>64</MaxClients>
    <Port>4508</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
</SimBase.Document>


The error log is:
10:12:40.6

---===+++===---

10:12:40.8 Starting Plan-G (W7 edition), build 3.1.2.101
10:12:40.8 OS is Microsoft Windows NT 6.1.7601 Service Pack 1
10:12:42.9 InitDataFolder
10:12:43.0 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FSX.sdf
10:12:43.0 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FS9.sdf
10:12:43.0 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_XPX.sdf
10:12:43.0 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_P3D.sdf
10:12:43.0 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_NAVI.sdf
10:12:43.0 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\UserWaypoints.sdf
10:12:43.0 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\MEF.sdf
10:12:47.7 Map tiles cache: C:\Users\Home\AppData\Local\GMap.NET\
10:12:49.2 Program in: C:\Program Files (x86)\Plan-G v3.1.2
10:12:49.2 Data in: C:\Users\Home\Documents\Plan-G Files
10:12:49.3 IsDataLoaded: FSX
10:12:49.3 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FSX.sdf
10:12:50.6 Starting timer
10:12:50.7 DownloadCurrentMetars thread started
10:12:50.8 Metar08Z.TXT started
10:12:50.8 sTAF06Z.TXT started
10:12:50.8 Metar09Z.TXT started
10:12:51.2 sTAF06Z.TXT done
10:12:51.2 lTAF06Z.TXT started
10:12:51.7 sTAF00Z.TXT started
10:12:51.7 lTAF06Z.TXT done
10:12:51.7 lTAF00Z.TXT started
10:12:51.8 sTAF00Z.TXT done
10:12:52.4 lTAF00Z.TXT done
10:12:52.7 IsDataLoaded: FSX
10:12:52.7 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FSX.sdf
10:12:52.8 IsDataLoaded: FS9
10:12:52.8 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FS9.sdf
10:12:53.0 IsDataLoaded: P3D
10:12:53.0 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_P3D.sdf
10:12:53.3 IsDataLoaded: XPlane
10:12:53.3 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_XPX.sdf
10:12:53.6 Metar09Z.TXT done
10:12:54.0 Metar08Z.TXT done
10:12:54.0 DownloadCurrentMetars done
10:12:54.3 Stopping timer
10:12:54.3 StartMap
10:12:54.5 Connection string: metadata=res://*/Data.FSData.csdl|res://*/Data.FSData.ssdl|res://*/Data.FSData.msl;provider=System.Data.SqlServerCe.3.5;provider connection string='Data Source=|DataDirectory|\Data\PlanG3_FSX.sdf'
10:12:55.6 ProcessMetars done
10:12:59.2 NdbsInBounds 12
10:12:59.7 VorsInBounds 12
10:13:00.5 AirportsInBounds 29
10:13:03.2 AirspaceInBounds 63
10:13:03.5 NdbsInBounds 12
10:13:03.5 VorsInBounds 12
10:13:03.5 AirportsInBounds 29
10:13:03.6 AirspaceInBounds 63
10:13:06.9 _Backstage_IsOpenChanged: True
10:13:34.6 _Backstage_IsOpenChanged: False
10:13:35.0 Cleanup
10:15:06.1

---===+++===---

10:15:06.1 Starting Plan-G (W7 edition), build 3.1.2.101
10:15:06.2 OS is Microsoft Windows NT 6.1.7601 Service Pack 1
10:15:06.3 InitDataFolder
10:15:06.3 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FSX.sdf
10:15:06.3 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FS9.sdf
10:15:06.3 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_XPX.sdf
10:15:06.3 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_P3D.sdf
10:15:06.3 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_NAVI.sdf
10:15:06.3 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\UserWaypoints.sdf
10:15:06.3 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\MEF.sdf
10:15:07.2 Map tiles cache: C:\Users\Home\AppData\Local\GMap.NET\
10:15:07.4 Program in: C:\Program Files (x86)\Plan-G v3.1.2
10:15:07.4 Data in: C:\Users\Home\Documents\Plan-G Files
10:15:07.4 IsDataLoaded: FSX
10:15:07.4 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FSX.sdf
10:15:07.5 Starting timer
10:15:07.5 DownloadCurrentMetars thread started
10:15:07.5 Metar08Z.TXT started
10:15:07.5 Metar09Z.TXT started
10:15:07.5 sTAF06Z.TXT started
10:15:07.7 sTAF06Z.TXT done
10:15:07.7 lTAF06Z.TXT started
10:15:08.3 lTAF06Z.TXT done
10:15:08.3 sTAF00Z.TXT started
10:15:08.3 sTAF00Z.TXT done
10:15:08.3 lTAF00Z.TXT started
10:15:08.9 lTAF00Z.TXT done
10:15:09.1 IsDataLoaded: FSX
10:15:09.1 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FSX.sdf
10:15:09.2 IsDataLoaded: FS9
10:15:09.2 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FS9.sdf
10:15:09.2 IsDataLoaded: P3D
10:15:09.2 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_P3D.sdf
10:15:09.2 IsDataLoaded: XPlane
10:15:09.2 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_XPX.sdf
10:15:10.0 Metar08Z.TXT done
10:15:10.0 Stopping timer
10:15:10.0 StartMap
10:15:10.0 Connection string: metadata=res://*/Data.FSData.csdl|res://*/Data.FSData.ssdl|res://*/Data.FSData.msl;provider=System.Data.SqlServerCe.3.5;provider connection string='Data Source=|DataDirectory|\Data\PlanG3_FSX.sdf'
10:15:10.4 NdbsInBounds 14
10:15:10.5 VorsInBounds 14
10:15:10.9 AirportsInBounds 32
10:15:11.7 AirspaceInBounds 71
10:15:11.7 NdbsInBounds 14
10:15:11.7 VorsInBounds 14
10:15:11.8 AirportsInBounds 32
10:15:11.9 AirspaceInBounds 71
10:15:12.7 Metar09Z.TXT done
10:15:12.8 DownloadCurrentMetars done
10:15:14.0 ProcessMetars done
10:15:15.5 _Backstage_IsOpenChanged: True
10:16:01.0 _Backstage_IsOpenChanged: False
10:16:04.4 _Backstage_IsOpenChanged: True
10:16:16.6 _Backstage_IsOpenChanged: False
10:16:18.4 Initiating FSUIPC/XPUIPC connection.
10:16:18.5 FSUIPC/XPUIPC.Connect
10:16:18.6 Connect: FSUIPC.FSUIPCException: FSUIPC Error #2: FSUIPC_ERR_NOFS. Cannot find FSUIPC or WideFS running on this machine.
   at FSUIPC.FSUIPCConnection.Open(Byte ClassInstance, FlightSim RequiredFlightSimVersion)
   at Plan_G3.Model.MyFSUIPC.Connect()
10:16:18.7 SetFSConnected: System.NullReferenceException: Object reference not set to an instance of an object.
   at Plan_G3.Model.MyFSUIPC.Disconnect()
   at Plan_G3.Model.MyFSUIPC.Connect()
   at Plan_G3.ViewModel.MainViewModel.SetFSConnected(Boolean value)
10:16:50.2 NdbsInBounds 19
10:16:50.3 VorsInBounds 18
10:16:50.5 AirportsInBounds 41
10:16:51.0 AirspaceInBounds 82
10:16:52.1 NdbsInBounds 11
10:16:52.2 VorsInBounds 8
10:16:52.3 AirportsInBounds 28
10:16:52.6 AirspaceInBounds 79
10:17:17.1 NdbsInBounds 17
10:17:17.2 VorsInBounds 19
10:17:17.2 AirportsInBounds 39
10:17:17.4 AirspaceInBounds 79
10:19:00.3 _Backstage_IsOpenChanged: True
10:19:12.4 _Backstage_IsOpenChanged: False
10:19:23.9 Cleanup
10:19:36.3

---===+++===---

10:19:36.3 Starting Plan-G (W7 edition), build 3.1.2.101
10:19:36.3 OS is Microsoft Windows NT 6.1.7601 Service Pack 1
10:19:36.5 InitDataFolder
10:19:36.5 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FSX.sdf
10:19:36.5 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FS9.sdf
10:19:36.5 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_XPX.sdf
10:19:36.5 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_P3D.sdf
10:19:36.5 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_NAVI.sdf
10:19:36.5 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\UserWaypoints.sdf
10:19:36.5 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\MEF.sdf
10:19:37.4 Map tiles cache: C:\Users\Home\AppData\Local\GMap.NET\
10:19:37.6 Program in: C:\Program Files (x86)\Plan-G v3.1.2
10:19:37.6 Data in: C:\Users\Home\Documents\Plan-G Files
10:19:37.6 IsDataLoaded: FSX
10:19:37.6 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FSX.sdf
10:19:37.7 Starting timer
10:19:37.7 DownloadCurrentMetars thread started
10:19:37.7 Metar08Z.TXT started
10:19:37.7 Metar09Z.TXT started
10:19:37.7 sTAF06Z.TXT started
10:19:37.9 sTAF06Z.TXT done
10:19:37.9 lTAF06Z.TXT started
10:19:38.4 lTAF06Z.TXT done
10:19:38.4 sTAF00Z.TXT started
10:19:38.5 sTAF00Z.TXT done
10:19:38.5 lTAF00Z.TXT started
10:19:38.9 IsDataLoaded: FSX
10:19:38.9 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FSX.sdf
10:19:38.9 IsDataLoaded: FS9
10:19:38.9 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_FS9.sdf
10:19:38.9 IsDataLoaded: P3D
10:19:38.9 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_P3D.sdf
10:19:38.9 IsDataLoaded: XPlane
10:19:38.9 Data Source = C:\Users\Home\Documents\Plan-G Files\Data\PlanG3_XPX.sdf
10:19:39.1 lTAF00Z.TXT done
10:19:40.0 Metar09Z.TXT done
10:19:40.1 Metar08Z.TXT done
10:19:40.1 DownloadCurrentMetars done
10:19:40.2 Stopping timer
10:19:40.2 StartMap
10:19:40.2 Connection string: metadata=res://*/Data.FSData.csdl|res://*/Data.FSData.ssdl|res://*/Data.FSData.msl;provider=System.Data.SqlServerCe.3.5;provider connection string='Data Source=|DataDirectory|\Data\PlanG3_FSX.sdf'
10:19:40.7 NdbsInBounds 17
10:19:40.8 VorsInBounds 19
10:19:41.4 AirportsInBounds 39
10:19:41.5 ProcessMetars done
10:19:42.2 AirspaceInBounds 79
10:19:42.3 NdbsInBounds 17
10:19:42.3 VorsInBounds 19
10:19:42.3 AirportsInBounds 39
10:19:42.4 AirspaceInBounds 79
10:19:46.5 _Backstage_IsOpenChanged: True
10:19:54.1 _Backstage_IsOpenChanged: False
10:19:55.6 Initiating SimConnect connection.
10:19:55.6 Connect
10:19:55.6 SimConnect.Connect - Remote. Mode = IPv4 Server = 192.168.1.146 Port = 4508
10:20:00.6 SimConnect connection attempt timed out
10:20:00.6 Disconnect
10:20:01.7 Disconnected from sim

Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: hlminx on August 02, 2015, 03:41:26 PM
After playing with this for almost 2 entire days, I think I have sorted my issue out..

There were quite a few things that I had to do to get it working, none of which were in the instruction documents so I will post them here in case it helps anyone else...

I had to install Microsoft SDK Client (via the SDK.msi) onto the networked machine.
I also needed to copy across the SimConnect.ini  from my SDK folder to  Documents>Flight Simulator X Files on the main machine.
I then updated the Port number in the SimConnect.XML so that it was 5000 
I then created a SimConnect.cfg file on the networked machine and added in the IP address of the FSX machine.

It just remains to be seen if I have to change the IP address each time I log on, but we'll see what happens!

So looking forward to getting up in the air with Plan G working.. :-)


 

Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: tim arnot on August 03, 2015, 06:55:53 AM
Thanks for the tips, and glad you finally got it sorted.

If your IPs are dynamic, there's a good chance they'll change over days, depending on the order you start things up. It's always better to reserve an IP for at least the FSX machine in your DHCP server/router.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: LittlePaulio on August 19, 2015, 02:26:10 AM
If you continue to have problems with Simconnect (I could never get it to work across a network) you should get a registered version of FSUIPC. It allows you to do so much with control assignments (multiple switchable functions for buttons, switches, throttle, creating macros and far more accurate calibration than FSX, and that's just the tip of the iceberg!) You can even write your own .Lua scripts that will allow you to customise any control the way you want to. That is, if someone hasn't already created it a script for the functionality you were looking for. It has a very active, productive userbase. You do need to read and learn some pretty technical stuff for the more advanced features, so it's not necessarily for everyone.
But it has also allowed me to stably connect to Plan-G on my laptop. You just need to download a tiny free server app that uses the FSUIPC inbuilt WideServer networking functionality when you start FSX. It's configured by simply entering an IP address and then putting the details it gives you (IP address, port number) into Plan-G and hit connect and it just works instantly for me. I have loads of add-on scenery but I still completely built my database in a couple of minutes. Plus you don't need to pay for WideFS or mess around with Simconnect.xml files. I don't mean to criticise anyone who has networking with Simconnect working, that's great for you, it is totally free! I still love FSUIPC though  as it just adds so many possibilities, especially if you have a controller(s) or any panels and switches. I have nothing to do with Pete Dowson (creator of FSUIPC), in fact I find that he can be quite rude and arrogant in his replies to paying customers, but he has created one hell of a piece of software! Just like Plan-G, which is just awesome, and teaching me so much about navigation in general, as well as the stuff specific to Flight Sims. And there is a lot to learn for the novice like me! But, it's just so interesting, interactive, visually appealing and exciting that you don't even realise all the knowledge you're absorbing. Congrats to the creators at TA Software for creating this wonderful program, and then sharing it for free. I can't praise you enough!

Anyway, enough excited rambling from me, time for my bed! G'night!
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: vortex on August 24, 2015, 11:30:58 PM
You just need to download a tiny free server app that uses the FSUIPC inbuilt WideServer networking functionality when you start FSX...

Where can I get the server app? I'd love to be able to connect Plan-G on my laptop over the network but without success using simconnect.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: LittlePaulio on September 17, 2015, 12:33:12 AM
I use one from Phawary Labs that connects to FSUIPC once FSX is running. I also mapped the drive FSX installed on to a network location that my laptop could access.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: aeugli on September 17, 2015, 05:17:57 AM
Hallo Tim,

what do you mean with "If your IPs are dynamic, there's a good chance they'll change over days, depending on the order you start things up."
If could explain it a little more detailed, it would be much appreciated by me and may be others!
Thanks in advance for your reply.
Regards
Rainer
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: tim arnot on September 17, 2015, 04:15:16 PM
Your router will allocate IPs in the order they are requested. So if one day you start your computers and devices in a different order, they will not get the same IPs. Simple as that.

If you want to guarantee your computer will always get the same IP, you need to reserve an address for it within the router. See your router's documentation for how that is done.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: aeugli on September 18, 2015, 04:53:56 AM
Thanks Tim for your clarification; I will do that!
Cheers Rainer
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: pmb on September 21, 2015, 08:20:45 PM
I set the IPs for my machines under Windows network/adater settings on the respective machines, which did work as well. I feel a bit uneasy messing with the router.

Kind regards, Michael
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: tim arnot on September 23, 2015, 06:09:00 PM
I set the IPs for my machines under Windows network/adater settings on the respective machines, which did work as well. I feel a bit uneasy messing with the router.

Kind regards, Michael

That's fine so long you use addresses that your router is not going to allocate to something else, otherwise you could potentially have a conflict if another device gets the same address that you manually allocated.
Title: Re: Connecting Plan G over network (simconnect) TIP
Post by: FlyingAxx on October 09, 2015, 02:53:28 PM
I set the IPs for my machines under Windows network/adater settings on the respective machines, which did work as well. I feel a bit uneasy messing with the router.

Kind regards, Michael

That's fine so long you use addresses that your router is not going to allocate to something else, otherwise you could potentially have a conflict if another device gets the same address that you manually allocated.
Most routers nowadays are too smart for doing that. However, usually they are allocating addresses above a certain threshold, e.g 200