Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - tim arnot

Pages: [1] 2 3 ... 274
1
Plan-G / Re: Can't make remote Plan-G work with P3D v4.1
« on: November 20, 2017, 06:43:13 PM »
The next step is to look at the simconnect log file. For this you will need to activate simconnect logging:

Create a SimConnect.ini file in your My Documents\Prepar3D Files folder.

Paste into it the following:

Quote
[SimConnect]
level=verbose
console=1
file=c:\simconnect%03u.log
file_next_index=0
file_max_index=9

This will create a simconnect000.log file in your C:\ folder (you may change the path) when P3d runs. Beware, it will get very big very quickly.

Run P3d and Plan-G and attempt to connect.
Close down P3d.
Open the log file in notepad and search for any references to Plan-G. Report back what it says.

When you're done, you'll want to remove or rename this ini file, otherwise it'll quickly fill up your hard drive with log files!

2
Plan-G / Re: 3.2 times out, 3-Beta works
« on: November 20, 2017, 06:30:14 PM »
Please try the attached test build. Back up your existing Plan-G3.exe, then Unzip it into your Plan-G folder.

Note that it will clear your settings.

3
Plan-G / Re: Can't make remote Plan-G work with P3D v4.1
« on: November 19, 2017, 11:17:56 PM »
1. Check is that you can ping the P3D machine from your laptop. To do this, open a cmd window ("Run CMD") and type Ping 192.168.1.103 at the command prompt.

2. Check is that you are trying to connect via "Simconnect (P3D)" and not "Simconnect (FSX)". You didn't include your log, so I can't check myself.

3. Check permissions - are both programs being run as administrator?

4. Maybe that port number is in use, or maybe it's being blocked by antivirus or firewall programs

The example in the pinned post is copied straight off my PC & laptop, so I know it works, cos I regularly use it! BTW, you shouldn't need to run SimConnect installers - Plan-G comes with everything it needs.

4
Plan-G / Re: V3.2.0 does not load database
« on: November 19, 2017, 11:03:19 PM »
That may not be a problem, as further reading suggests the update installs 4.6 as well as 4.7. It may still not be installed correctly - it's not uncommon for DotNet updates to screw up, in which case you can normally fix it by rerunning the patches from Windows Update.

5
Plan-G / Re: 3.2 times out, 3-Beta works
« on: November 19, 2017, 10:33:16 PM »
Plan hyphen G Files, not Plan underscore G Files.

6
Plan-G / Re: Using Radio Stack crashes PlanG
« on: November 19, 2017, 09:57:05 AM »
Hmm. Ok.

7
Plan-G / Re: V3.2.0 does not load database
« on: November 19, 2017, 09:56:30 AM »
Yes. With DotNet, you always need the specific version(s).

8
Plan-G / Re: 3.2 times out, 3-Beta works
« on: November 18, 2017, 11:52:32 AM »
As I said above, you cannot rename the Plan-G Files folder, only relocate it.

9
Plan-G / Re: Plan-G do not show me VOR & NDB
« on: November 18, 2017, 11:03:43 AM »
The screenshot in your first post had FSX data selected, NOT P3D. Using your database with P3D selected, this is what I see:

(upper airspace limit adjusted to reduce the Class A spaghetti that FSAerodata generates over the UK)

Your database file is a lot smaller than mine for some reason, but I couldn't spot any obvious gaps in coverage.

10
Plan-G / Re: Plan-G do not show me VOR & NDB
« on: November 18, 2017, 10:26:58 AM »
Thanks, I'll take a look at it.

11
Plan-G / Re: V3.2.0 does not load database
« on: November 18, 2017, 10:25:21 AM »
That is most likely your version of DotNet is out of date.

Please go to http://www.microsoft.com/Net/Download.aspx  and reinstall it. The version you need is 4.6.2

12
Plan-G / Re: 3.2 times out, 3-Beta works
« on: November 18, 2017, 10:23:03 AM »
That's because your "release" folder isn't the Plan-G Files folder.

Plan-G files are stored in My Documents\Plan-G Files\ and nowhere else.

v3.2 allows you to substitute "My Documents" for somewhere else, because it doesn't play nicely with systems that have "My Documents" on a Cloud drive.

But it's not relevant to setting up a Simconnect connection.

Another thing to check is, does your FS PC have a reserved IP address? If not, that has likely changed from the one in your cfg.

13
Plan-G / Re: Plan G Version 3.2.0.144 does not create Database for P3D V4
« on: November 18, 2017, 10:16:29 AM »
Um....?

Database merging is something for X-Plane, from the time when it didn't do airspace. That's of no benefit to you whatsoever.

As I said before, setting up the database is a straightforward process:

1. Install Plan-G on the P3D computer
2. Build the database for P3D on the P3D computer
3. Copy My Documents\Plan-G Files (including subfolders) from the P3D computer to the Plan-G computer
4. Run Plan-G on the Plan-G folder. Select the P3D Data button if it is not active.

When the sim is running and you want to see your aircraft on the map, you may Connect to the sim. See the sticky in the forum for instructions on setting up Simconnect for P3D.

14
Plan-G / Connecting SimConnect to P3dv4 in Plan-G 3.2
« on: November 18, 2017, 10:07:45 AM »
The P3D SimConnect library uses a much more "traditional" approach to connections than the beta FSX library. Here's how to set it up.

1.Create a Simconnext.xml file on the P3D computer, in the folder C:\Users\(me)\AppData\Roaming\Lockheed Martin\Prepar3D v4

Paste in (or type) the following:

Quote
<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect Server Configuration</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>

<!-- Example Global (remote) IPv4 Server Configuration-->
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <MaxClients>64</MaxClients>
    <Address>192.168.0.106</Address>
    <Port>4504</Port>
  </SimConnect.Comm>

</SimBase.Document>

Note the items in bold: "Address" is the IP address of your P3D PC. You can find it out by using the IPConfig command from a cmd prompt.
"Port" can be any free port number. You will need to remember it for the next step.

If you already have a Simconnect.xml and it's being used by some other addon, simply add a new entry to that file.

2. In your Plan-G program folder, create a Simconnect.cfg file.
Paste or type in the following:

Quote
[SimConnect]
Protocol=IPV4
Address=192.168.0.106
Port=4504
MaxReceiveSize=4096
DisableNagle=0


Note that the address and port numbers should be the same as those in the xml file.

Now, when you want to see your P3D aircraft in Plan-G, select "Simconnect (P3D) in the connect options, and click Connect.

If the connection should time out, check your application permissions (if P3D is running as Administrator, Plan-G must also run as Administrator), and make sure your firewall or antivirus is not blocking it.

Supplemental: You should set up your router to reserve an IP address for your P3D computer. This means that it will have the same address on your internal network every time you start it. If you just leave it to the default allocation, it could get different addresses each time, and you'll need to update both the xml and cfg files accordingly. Trust me, this is a pain in the butt.

15
Plan-G / Re: Using Radio Stack crashes PlanG
« on: November 18, 2017, 09:26:04 AM »
I'll take a look and see if I can reproduce it here.

Pages: [1] 2 3 ... 274