Recent Posts

Pages: [1] 2 3 ... 10
1
Plan-G / Install 3.2.0 and no VOR's show
« Last post by stamcomann on Yesterday at 07:50:11 PM »
After install of 3.2.0, all nav aids show except the VOR's.  They are checked in the box for zoom level 8 but do not show up at any zoom level.  How to correct
2
Plan-G / Re: Aircraft not showing up on networked pc
« Last post by bigmarty on Yesterday at 06:05:38 PM »
Thank you. I will get WifeFS.
3
Thank you. I'll incorporate that into the next build.
4
Plan-G / Re: V3.2.0 does not load database [Solved]
« Last post by tim arnot on Yesterday at 04:33:43 PM »
Interesting, the simconnect dll is supposed to be a fat binary (ie both 32 & 64 bits), and older versions of P3D are supposed to work with newer versions of Simconnect (at least, Simconnect is supposed to fall back for compatibility with older versions, or so I understood).

It seems that may not entirely be the case.

Thanks for the update, & glad you finally have it working. We live and learn...
5
Plan-G / Re: Aircraft not showing up on networked pc
« Last post by tim arnot on Yesterday at 04:27:18 PM »
You need WideFS to use FSUIPC across a network.
6
Hello,

The build of the P3D database would fail on my system with the error dialog "Failed to build database (The type initializer for 'ExtentPlaceholderCreator' threw an exception.) See log file for more details."

The Plan-G_Log.txt log file showed the following repeating exceptions:

    3:17:44.2 Route: System.TypeInitializationException: The type initializer for 'ExtentPlaceholderCreator' threw an exception. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target   
    of an invocation. ---> System.EntryPointNotFoundException: Unable to find an entry point named 'SetClrFeatureSwitchMap' in DLL 'SqlServerSpatial110.dll'.
       at Microsoft.SqlServer.Types.GLNativeMethods.SetClrFeatureSwitchMap(Int32 clrFeatureSwitchMap)
       at Microsoft.SqlServer.Types.SqlGeometry.IsValidExpensive()
       at Microsoft.SqlServer.Types.SqlGeometry.Construct(GeoData g, Int32 srid)
       at Microsoft.SqlServer.Types.SqlGeometry.GeometryFromText(OpenGisType type, SqlChars text, Int32 srid)
       at Microsoft.SqlServer.Types.SqlGeometry.STGeomFromText(SqlChars geometryTaggedText, Int32 srid)
       at Microsoft.SqlServer.Types.SqlGeometry.Parse(SqlString s)
       --- End of inner exception stack trace ---

I am not sure if PLan-G only uses the version of SqlServerSpatial110.dll that is included with the program and updated SQL Server Express 2012 to SP4 which did not help. After some searching on the Internet it appeared that this error is related to a known issue with SQL Server 2012 / the SqlServerSpatial110.dll. A workaround was suggested and I added the following assembly redirection to the assemblyBinding element in the Plan-G3.exe.config file (Default path: C:\Program Files (x86)\Plan-G v3.2.0\Plan-G3.exe.config):

    <dependentAssembly>
      <assemblyIdentity name="Microsoft.SqlServer.Types" publicKeyToken="89845dcd8080cc91" />
      <bindingRedirect oldVersion="1.0.0.0-11.0.0.0" newVersion="10.0.0.0" />
    </dependentAssembly>

After this change the database build completed without errors and i have not seen any other issues.
I am posting it here because i couldn't find any similar information on the the forum and it might help someone else.

System Specifications:
P3D 4.2.21.24048
Plan-G 3.2.0.144
Windows 10 Pro 64Bit - Build 16299.248
Microsoft SQL Server 2012 Express LocalDB (11.4.7001.0)

7
Plan-G / Re: V3.2.0 does not load database [Solved]
« Last post by jank1 on Yesterday at 12:10:24 PM »
Version 3.2 is up and running.
Yesterday somthing struck my mind, 32 vs 64 bit version.
I replaced your version of LockheedMartin.Prepar3D.SimConnect.dll to the version from P3D v2.5 SDK.
The loadingprocess worked OK.
A little bit copying between the Documents\PlanG Files and the Documents\Plan-G Files 3-2 and the program works OK.
Sorry Microsoft, .NET was not the problem this time.
8
Plan-G / Re: Aircraft not showing up on networked pc
« Last post by bigmarty on Yesterday at 04:25:42 AM »
I don't have a message like that in the title bar, just Connect or Disconnect. I have registered copy of FSUIPC 4.972 but do not have Widefs. Is this my problem?

Thanks for your reply.
9
Plan-G / Re: Aircraft not showing up on networked pc
« Last post by tim arnot on Yesterday at 12:29:13 AM »
Does the FS title bar change from "Waiting for clients" to "1 connected" when you make the connection?

(I am assuming you have registered WideFS as well as registered FSUIPC - WideFS will not work unregistered)
10
Plan-G / Re: Plan G and Flight Planner in P3Dv4.1
« Last post by bobbykins on February 23, 2018, 08:15:20 PM »
Hi Tim --thanks for the prompt reply and with your input I simply moved an existing PLN folder from the Plan G folder  to the correct one. I also made sure that the path was set properly in the Export box. Went to the Flight Planner, I can see the available flights "on the board", click on the one I want and it loads in the flight planner and GPS, all the connections are made between P3D and the Plan G and away we go. I have now produced several plans as further trials and all seems to work as it did before in FSX.
But, for some reason, if I try to locate the flight using the browse button and scroll down the window that is presented, it does not appear in any of the folders .
Never mind for the mo. as it is working  and I will ponder more, unless you have any other suggestions.
Now ,all I need to get working properly (without Spadnext! ) is the radio panels, (I am in dialogue with Logitech) but I am not totally lost as your pop up panels to tune the radios have worked really well for me in the past and it seems that they will be getting a lot more use in the near future.
Many thanks.
Bobbykins
Pages: [1] 2 3 ... 10